Einfacher HID-Device-Zugriff

Bibliothek für einfachen Zugriff auf HID-Devices
Einfacher HID-Device-Zugriff
Feedback senden
Der SimpleGenericHid Namespace bietet einen einfachen Zugriff auf HID-Devices.

Die Klasse HidDeviceManagament bietet statische Methoden zur Emittlung der aktuell angeschlossenen Geräte. Ein ermitteltes Gerät kann Datenblöcke senden und empfangen.

Sowohl HidDeviceManagament als auch die einzelnen Devices halten den Anschlusszustand aktuell. Applikationen erhalten über Events Nachricht über neu angeschlossene und entfernte Geräte.

Alternativ besteht die Möglichkeit eine Instanz der HDMControl auf einer Form zu platzieren.

Siehe auch Ullis Roboter Seite.

Namespaces

Namespace | Beschreibung
SimpleGenericHid | .NET Klassenbibliothek für einfachen Zugriff auf HID-Devices

Senden Sie Kommentare zu diesem Feature an bienonline[NoSpam]gmx.de


SimpleGenericHid Namespace

SimpleGenericHid Namespace
Feedback senden
.NET Klassenbibliothek für einfachen Zugriff auf HID-Devices

Klassen

Klasse | Beschreibung
HDMControl | Bietet die Möglichkeit HidDeviceManagament als Komponenten auf eine Form zu platzieren.
HidDevice | Repräsentiert ein HID-Device.
HidDeviceManagament | Die HidDeviceManagament-Klasse bietet statische Methoden zum Zugriff auf HID-Devices
HidException | Exception-Klasse für diese Bibliothek


HDMControl Klasse

HDMControl Klasse
Member Siehe auch Feedback senden
Bietet die Möglichkeit HidDeviceManagament als Komponenten auf eine Form zu platzieren.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Class HDMControl _
    Inherits Component

Hinweise

Wrapper für HidDeviceManagament.

Vererbungshierarchie

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
SimpleGenericHid..::.HDMControl

Siehe auch

HDMControl Member
SimpleGenericHid Namespace


HDMControl Member

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HDMControl Member
HDMControl Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Feedback senden

Der Typ HDMControl stellt folgende Member bereit:

Konstruktoren

Name | Beschreibung
HDMControl | Initializes a new instance of the HDMControl class

Methoden

Name | Beschreibung
FindDevices | Filtert die Liste der aktuell angeschlossenen HID-Devices auf solche, die bestimmte Eigenschaften besitzen.

Eigenschaften

Name | Beschreibung
DeviceList | Stellt eine Liste aller aktuell angeschlossenen HID-Devices bereit.

Ereignisse

Name | Beschreibung
DeviceArrived | Dieses Ergeinis wird ausgelöst, wenn ein neues HID-Device vom Betriebssystem erkannt wird.
DeviceRemoved | Dieses Ereignis wird ausgelöst, wenn ein HID-Device nicht mehr zur Verfügung steht.

Siehe auch

HDMControl Klasse


HDMControl Konstruktor

HDMControl Konstruktor
HDMControl Klasse Siehe auch Feedback senden
Initializes a new instance of the HDMControl class

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Sub New

HDMControl Klasse


HDMControl Methoden

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HDMControl Methoden
HDMControl Klasse Siehe auch Feedback senden

Der Typ HDMControl stellt folgende Member bereit:

Methoden

Name | Beschreibung
FindDevices | Filtert die Liste der aktuell angeschlossenen HID-Devices auf solche, die bestimmte Eigenschaften besitzen.

HDMControl Klasse


FindDevices Methode

HDMControl..::.FindDevices Methode
HDMControl Klasse Siehe auch Feedback senden
Filtert die Liste der aktuell angeschlossenen HID-Devices auf solche, die bestimmte Eigenschaften besitzen.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Function FindDevices ( _
    VendorID As Integer, _
    ProductID As Integer, _
    VersionNumber As Integer, _
    Manufacturer As String, _
    SerialNumber As String, _
    ProductName As String _
) As List(Of HidDevice)

Parameters

VendorID
Type: System..::.Int32
optional: gewünschte Vendor ID.
ProductID
Type: System..::.Int32
optional: gewünschte Product ID.
VersionNumber
Type: System..::.Int32
optional: gewünschte Versionsnummer.
Manufacturer
Type: System..::.String
optional: gewünschter Manufacturer-String.
SerialNumber
Type: System..::.String
optional: gewünschter SerialNumber-String.
ProductName
Type: System..::.String
optional: gewünschter ProductName-String.

Rückgabewert

Liste der HID-Devices, auf die alle angegebenen Eigenschaften zutreffen.

HDMControl Klasse


HDMControl Eigenschaften

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HDMControl Eigenschaften
HDMControl Klasse Siehe auch Feedback senden

Der Typ HDMControl stellt folgende Member bereit:

Eigenschaften

Name | Beschreibung
DeviceList | Stellt eine Liste aller aktuell angeschlossenen HID-Devices bereit.

HDMControl Klasse


DeviceList Eigenschaft

HDMControl..::.DeviceList Eigenschaft
HDMControl Klasse Siehe auch Feedback senden
Stellt eine Liste aller aktuell angeschlossenen HID-Devices bereit.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property DeviceList As ReadOnlyCollection(Of HidDevice)

Eigenschaftswert

Liste aller aktuell angeschlossenen HID-Devices.

Hinweise

Die Liste ist readonly.

HDMControl Klasse


HDMControl Ereignisse

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HDMControl Ereignisse
HDMControl Klasse Siehe auch Feedback senden

Der Typ HDMControl stellt folgende Member bereit:

Ereignisse

Name | Beschreibung
DeviceArrived | Dieses Ergeinis wird ausgelöst, wenn ein neues HID-Device vom Betriebssystem erkannt wird.
DeviceRemoved | Dieses Ereignis wird ausgelöst, wenn ein HID-Device nicht mehr zur Verfügung steht.

HDMControl Klasse


DeviceArrived Ereignis

HDMControl..::.DeviceArrived Ereignis
HDMControl Klasse Siehe auch Feedback senden
Dieses Ergeinis wird ausgelöst, wenn ein neues HID-Device vom Betriebssystem erkannt wird.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Event DeviceArrived As DeviceArrivedEventHandler

HDMControl Klasse


DeviceRemoved Ereignis

HDMControl..::.DeviceRemoved Ereignis
HDMControl Klasse Siehe auch Feedback senden
Dieses Ereignis wird ausgelöst, wenn ein HID-Device nicht mehr zur Verfügung steht.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Event DeviceRemoved As DeviceRemovedEventHandler

Hinweise

HDMControl Klasse


HidDevice Klasse

HidDevice Klasse
Member Siehe auch Feedback senden
Repräsentiert ein HID-Device.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Class HidDevice

Hinweise

Angeschlossene HID-Devices können über Methoden der HidDeviceManagament-Klasse abgerufen werden.

Vererbungshierarchie

System..::.Object
SimpleGenericHid..::.HidDevice

HidDevice Member


HidDevice Member

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidDevice Member
HidDevice Klasse Methoden Eigenschaften Ereignisse Siehe auch Feedback senden

Der Typ HidDevice stellt folgende Member bereit:

Methoden

Name | Beschreibung
Close | Schließt die Verbindung zum Device.
GetDataBlock | Ruft einen Datenblock vom Device ab.
Open | Öffnet eine logische Verbindung zum zu Grunde liegenden HID-Device her.
SendDataBlock | Sendet eine Datenblock an das Device.

Eigenschaften

Name | Beschreibung
DataBlockSize | Liefert die (madximale) Größe des zum Datenaustauch genutzten Datenblocks in Byte.
DevicePathName | Liefert den DevicePathName des Devices.
IsConnected | Liefer einen Wert, der angibt, ob das Device weiterhin angeschlossen ist.
IsOpen | Liefer einen Wert, der angibt, ob eine Verbindung zum Gerät besteht.
Manufacturer | Liefert den Manufacturer-String des Devices.
ProductID | Liefert die ProductID des Devices.
ProductName | Liefert den ProductName-String des Devices.
SerialNumber | Liefert den SerialNummer-String des Devices.
VendorID | Liefert die VendorID des Devices.
VersionNumber | Liefert die VersionNumber des Devices.

Ereignisse

Name | Beschreibung
DeviceRemoved | Das DeviceRemoved-Ereignis wird ausgelöst, wenn das Device vom System entfernt wurde.

HidDevice Klasse


HidDevice Methoden

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidDevice Methoden
HidDevice Klasse Siehe auch Feedback senden

Der Typ HidDevice stellt folgende Member bereit:

Methoden

Name | Beschreibung
Close | Schließt die Verbindung zum Device.
GetDataBlock | Ruft einen Datenblock vom Device ab.
Open | Öffnet eine logische Verbindung zum zu Grunde liegenden HID-Device her.
SendDataBlock | Sendet eine Datenblock an das Device.

HidDevice Klasse


Close Methode

HidDevice..::.Close Methode
HidDevice Klasse Siehe auch Feedback senden
Schließt die Verbindung zum Device.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Sub Close

Hinweise

HidDevice Klasse


GetDataBlock Methode

HidDevice..::.GetDataBlock Methode
HidDevice Klasse Siehe auch Feedback senden
Ruft einen Datenblock vom Device ab.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Function GetDataBlock As Byte()

Rückgabewert

Den abgerufenen Datenblock.

Hinweise

Der Datenaustauch erfolgt über einen Feature-Report mit der Report-ID 1. Das Device muss für den Datenaustausch über diesen Reporttyp vorbereitet sein.

HidDevice Klasse


Open Methode

HidDevice..::.Open Methode
HidDevice Klasse Siehe auch Feedback senden
Öffnet eine logische Verbindung zum zu Grunde liegenden HID-Device her.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Sub Open

Hinweise

Technisch wird ein FileHandle abgerufen.

HidDevice Klasse


SendDataBlock Methode

HidDevice..::.SendDataBlock Methode
HidDevice Klasse Siehe auch Feedback senden
Sendet eine Datenblock an das Device.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Sub SendDataBlock ( _
    Data As Byte() _
)

Parameters

Data
Type: array< System..::.Byte >[]()[]
Der zu sendende Datenblock. Größe darf DataBlockSize nicht überschreiten.

Hinweise

Der Datenaustauch erfolgt über einen Feature-Report mit der Report-ID 1. Das Device muss für den Datenaustausch über diesen Reporttyp vorbereitet sein.

Der Datenblock wird vor dem Senden auf die maximale Größe mit 0 aufgefüllt.

HidDevice Klasse


HidDevice Eigenschaften

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidDevice Eigenschaften
HidDevice Klasse Siehe auch Feedback senden

Der Typ HidDevice stellt folgende Member bereit:

Eigenschaften

Name | Beschreibung
DataBlockSize | Liefert die (madximale) Größe des zum Datenaustauch genutzten Datenblocks in Byte.
DevicePathName | Liefert den DevicePathName des Devices.
IsConnected | Liefer einen Wert, der angibt, ob das Device weiterhin angeschlossen ist.
IsOpen | Liefer einen Wert, der angibt, ob eine Verbindung zum Gerät besteht.
Manufacturer | Liefert den Manufacturer-String des Devices.
ProductID | Liefert die ProductID des Devices.
ProductName | Liefert den ProductName-String des Devices.
SerialNumber | Liefert den SerialNummer-String des Devices.
VendorID | Liefert die VendorID des Devices.
VersionNumber | Liefert die VersionNumber des Devices.

HidDevice Klasse


DataBlockSize Eigenschaft

HidDevice..::.DataBlockSize Eigenschaft
HidDevice Klasse Siehe auch Feedback senden
Liefert die (madximale) Größe des zum Datenaustauch genutzten Datenblocks in Byte.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property DataBlockSize As Integer

Eigenschaftswert

Größe des Datenblock in Byte.

HidDevice Klasse


DevicePathName Eigenschaft

HidDevice..::.DevicePathName Eigenschaft
HidDevice Klasse Siehe auch Feedback senden
Liefert den DevicePathName des Devices.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property DevicePathName As String

Eigenschaftswert

Der DevicePathName des Devices.

HidDevice Klasse


IsConnected Eigenschaft

HidDevice..::.IsConnected Eigenschaft
HidDevice Klasse Siehe auch Feedback senden
Liefer einen Wert, der angibt, ob das Device weiterhin angeschlossen ist.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property IsConnected As Boolean

Eigenschaftswert

True, wenn das Gerät weiterhin angeschlossen ist. False, wenn es entfernt wurde.

HidDevice Klasse


IsOpen Eigenschaft

HidDevice..::.IsOpen Eigenschaft
HidDevice Klasse Siehe auch Feedback senden
Liefer einen Wert, der angibt, ob eine Verbindung zum Gerät besteht.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property IsOpen As Boolean

Eigenschaftswert

True, wenn eine Verbindung zum Gerät besteht, ansonsten False.

HidDevice Klasse


Manufacturer Eigenschaft

HidDevice..::.Manufacturer Eigenschaft
HidDevice Klasse Siehe auch Feedback senden
Liefert den Manufacturer-String des Devices.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property Manufacturer As String

Eigenschaftswert

Der Manufacturer-String des Devices.

HidDevice Klasse


ProductID Eigenschaft

HidDevice..::.ProductID Eigenschaft
HidDevice Klasse Siehe auch Feedback senden
Liefert die ProductID des Devices.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property ProductID As Integer

Eigenschaftswert

Die ProductID des Devices.

HidDevice Klasse


ProductName Eigenschaft

HidDevice..::.ProductName Eigenschaft
HidDevice Klasse Siehe auch Feedback senden
Liefert den ProductName-String des Devices.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property ProductName As String

Eigenschaftswert

Der ProductName-String des Devices.

HidDevice Klasse


SerialNumber Eigenschaft

HidDevice..::.SerialNumber Eigenschaft
HidDevice Klasse Siehe auch Feedback senden
Liefert den SerialNummer-String des Devices.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property SerialNumber As String

Eigenschaftswert

Der SerialNummer-String des Devices.

HidDevice Klasse


VendorID Eigenschaft

HidDevice..::.VendorID Eigenschaft
HidDevice Klasse Siehe auch Feedback senden
Liefert die VendorID des Devices.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property VendorID As Integer

Eigenschaftswert

Die VendorID des Devices.

HidDevice Klasse


VersionNumber Eigenschaft

HidDevice..::.VersionNumber Eigenschaft
HidDevice Klasse Siehe auch Feedback senden
Liefert die VersionNumber des Devices.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public ReadOnly Property VersionNumber As Integer

Eigenschaftswert

Die VersionNumber des Devices.

HidDevice Klasse


HidDevice Ereignisse

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidDevice Ereignisse
HidDevice Klasse Siehe auch Feedback senden

Der Typ HidDevice stellt folgende Member bereit:

Ereignisse

Name | Beschreibung
DeviceRemoved | Das DeviceRemoved-Ereignis wird ausgelöst, wenn das Device vom System entfernt wurde.

HidDevice Klasse


DeviceRemoved Ereignis

HidDevice..::.DeviceRemoved Ereignis
HidDevice Klasse Siehe auch Feedback senden
Das DeviceRemoved-Ereignis wird ausgelöst, wenn das Device vom System entfernt wurde.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Event DeviceRemoved As DeviceRemovedEventHandler

Hinweise

Dieses Ereignis wird nur dann ausglöst, wenn das durch dieses Object repräsentierte Device entfernt wurde. Informationen über alle Devices erhält man über die HidDeviceManagament-Klasse.

HidDevice Klasse


HidDeviceManagament Klasse

HidDeviceManagament Klasse
Member Siehe auch Feedback senden
Die HidDeviceManagament-Klasse bietet statische Methoden zum Zugriff auf HID-Devices

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Class HidDeviceManagament

Hinweise

Die Klasse nicht instanziert werden. Eine statische Instanz zur Anbindung an die Ereinisse kann über GetInstance()()() abgerufen werden.

Dim withevents HDM = HidDeviceManagament.GetInstance

Vererbungshierarchie

System..::.Object
SimpleGenericHid..::.HidDeviceManagament

HidDeviceManagament Member


HidDeviceManagament Member

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidDeviceManagament Member
HidDeviceManagament Klasse Methoden Eigenschaften Ereignisse Siehe auch Feedback senden

Der Typ HidDeviceManagament stellt folgende Member bereit:

Methoden

Name | Beschreibung
FindDevices | Filtert die Liste der aktuell angeschlossenen HID-Devices auf solche, die bestimmte Eigenschaften besitzen.
GetInstance | Liefert eine Referenz auf eine statische Instanz der HidDeviceManagament-Klasse (Singleton).

Eigenschaften

Name | Beschreibung
DeviceList | Stellt eine Liste aller aktuell angeschlossenen HID-Devices bereit.

Ereignisse

Name | Beschreibung
DeviceArrived | Dieses Ergeinis wird ausgelöst, wenn ein neues HID-Device vom Betriebssystem erkannt wird.
DeviceRemoved | Dieses Ereignis wird ausgelöst, wenn ein HID-Device nicht mehr zur Verfügung steht.

HidDeviceManagament Klasse


HidDeviceManagament Methoden

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidDeviceManagament Methoden
HidDeviceManagament Klasse Siehe auch Feedback senden

Der Typ HidDeviceManagament stellt folgende Member bereit:

Methoden

Name | Beschreibung
FindDevices | Filtert die Liste der aktuell angeschlossenen HID-Devices auf solche, die bestimmte Eigenschaften besitzen.
GetInstance | Liefert eine Referenz auf eine statische Instanz der HidDeviceManagament-Klasse (Singleton).

HidDeviceManagament Klasse


FindDevices Methode

HidDeviceManagament..::.FindDevices Methode
HidDeviceManagament Klasse Siehe auch Feedback senden
Filtert die Liste der aktuell angeschlossenen HID-Devices auf solche, die bestimmte Eigenschaften besitzen.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Shared Function FindDevices ( _
    VendorID As Integer, _
    ProductID As Integer, _
    VersionNumber As Integer, _
    Manufacturer As String, _
    SerialNumber As String, _
    ProductName As String _
) As List(Of HidDevice)

Parameters

VendorID
Type: System..::.Int32
optional: gewünschte Vendor ID.
ProductID
Type: System..::.Int32
optional: gewünschte Product ID.
VersionNumber
Type: System..::.Int32
optional: gewünschte Versionsnummer.
Manufacturer
Type: System..::.String
optional: gewünschter Manufacturer-String.
SerialNumber
Type: System..::.String
optional: gewünschter SerialNumber-String.
ProductName
Type: System..::.String
optional: gewünschter ProductName-String.

Rückgabewert

Liste der HID-Devices, auf die alle angegebenen Eigenschaften zutreffen.

HidDeviceManagament Klasse


GetInstance Methode

HidDeviceManagament..::.GetInstance Methode
HidDeviceManagament Klasse Siehe auch Feedback senden
Liefert eine Referenz auf eine statische Instanz der HidDeviceManagament-Klasse (Singleton).

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Shared Function GetInstance As HidDeviceManagament

Rückgabewert

Referenz auf eine statische Instanz der HidDeviceManagament-Klasse.

Hinweise

Die statische Instanz dient zur Anbindung an die Ereignisse dieser Klasse per Basic-Syntax ('withevents' und 'handles')

HidDeviceManagament Klasse


HidDeviceManagament Eigenschaften

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidDeviceManagament Eigenschaften
HidDeviceManagament Klasse Siehe auch Feedback senden

Der Typ HidDeviceManagament stellt folgende Member bereit:

Eigenschaften

Name | Beschreibung
DeviceList | Stellt eine Liste aller aktuell angeschlossenen HID-Devices bereit.

HidDeviceManagament Klasse


DeviceList Eigenschaft

HidDeviceManagament..::.DeviceList Eigenschaft
HidDeviceManagament Klasse Siehe auch Feedback senden
Stellt eine Liste aller aktuell angeschlossenen HID-Devices bereit.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Shared ReadOnly Property DeviceList As ReadOnlyCollection(Of HidDevice)

Eigenschaftswert

Liste aller aktuell angeschlossenen HID-Devices.

Hinweise

Die Liste ist readonly.

HidDeviceManagament Klasse


HidDeviceManagament Ereignisse

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidDeviceManagament Ereignisse
HidDeviceManagament Klasse Siehe auch Feedback senden

Der Typ HidDeviceManagament stellt folgende Member bereit:

Ereignisse

Name | Beschreibung
DeviceArrived | Dieses Ergeinis wird ausgelöst, wenn ein neues HID-Device vom Betriebssystem erkannt wird.
DeviceRemoved | Dieses Ereignis wird ausgelöst, wenn ein HID-Device nicht mehr zur Verfügung steht.

HidDeviceManagament Klasse


DeviceArrived Ereignis

HidDeviceManagament..::.DeviceArrived Ereignis
HidDeviceManagament Klasse Siehe auch Feedback senden
Dieses Ergeinis wird ausgelöst, wenn ein neues HID-Device vom Betriebssystem erkannt wird.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Shared Event DeviceArrived As DeviceArrivedEventHandler

HidDeviceManagament Klasse


DeviceRemoved Ereignis

HidDeviceManagament..::.DeviceRemoved Ereignis
HidDeviceManagament Klasse Siehe auch Feedback senden
Dieses Ereignis wird ausgelöst, wenn ein HID-Device nicht mehr zur Verfügung steht.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Shared Event DeviceRemoved As DeviceRemovedEventHandler

Hinweise

HidDeviceManagament Klasse


HidException Klasse

HidException Klasse
Member Siehe auch Feedback senden
Exception-Klasse für diese Bibliothek

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Class HidException _
    Inherits Exception

Hinweise

Alle Exceptions dieser Bibliothek.

Vererbungshierarchie

System..::.Object
System..::.Exception
SimpleGenericHid..::.HidException

HidException Member


HidException Member

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidException Member
HidException Klasse Konstruktoren Methoden Siehe auch Feedback senden

Der Typ HidException stellt folgende Member bereit:

Konstruktoren

Name | Beschreibung
HidException | Überladen.

Methoden

Name | Beschreibung
GenerateWithWinError | Estellt eine neue Instanz der HidException-Klasse. Die Fehlernummer des letzten Windows-API-Fehlers wird angefügt.

HidException Klasse


HidException Konstruktor

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidException Konstruktor
HidException Klasse Siehe auch Feedback senden

Overload List

Name | Beschreibung
HidException()()() | Initialisiert eine neue Instanz der HidException-Klasse.
HidException(String) | Initialisiert eine neue Instanz der HidException-Klasse.

Siehe auch

HidException Klasse
HidException Member


HidException Konstruktor

HidException Konstruktor
HidException Klasse Siehe auch Feedback senden
Initialisiert eine neue Instanz der HidException-Klasse.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Sub New

Siehe auch

HidException Klasse
HidException Overload


HidException Konstruktor (String)

HidException Konstruktor (String)
HidException Klasse Siehe auch Feedback senden
Initialisiert eine neue Instanz der HidException-Klasse.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Sub New ( _
    msg As String _
)

Parameters

msg
Type: System..::.String
Information zur Exception.

Siehe auch

HidException Klasse
HidException Overload


HidException Methoden

[image]

Bibliothek für einfachen Zugriff auf HID-Devices
HidException Methoden
HidException Klasse Siehe auch Feedback senden

Der Typ HidException stellt folgende Member bereit:

Methoden

Name | Beschreibung
GenerateWithWinError | Estellt eine neue Instanz der HidException-Klasse. Die Fehlernummer des letzten Windows-API-Fehlers wird angefügt.

HidException Klasse


GenerateWithWinError Methode

HidException..::.GenerateWithWinError Methode
HidException Klasse Siehe auch Feedback senden
Estellt eine neue Instanz der HidException-Klasse. Die Fehlernummer des letzten Windows-API-Fehlers wird angefügt.

Namespace: SimpleGenericHid
Assembly: SimpleGenericHid (in SimpleGenericHid.dll) Version: 1.0.3970.18007 (1.0.0.0)

Syntax

Visual Basic (Deklaration)
Public Shared Function GenerateWithWinError ( _
    strMessage As String _
) As HidException

Parameters

strMessage
Type: System..::.String
Information zur Exception.

Rückgabewert

Eine neue Instanz der HidException-Klasse

Hinweise

Bespielcode:

CopyC#
Throw HidException.GenerateWithWinError("Message").

HidException Klasse